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What is VoiceSauce

• VoiceSauce is a software that can be used to analyze acoustic 
measurements related to voicing (Shue et al., 2010).

• Compared to Praat, VoiceSauce specializes in measuring parameters 
related to voice quality:
• Spectral tilt (H1-H2, H2-H4), noise (HNR), voicing amplitude (SoE). Those 

measures indicate whether there is glottal constriction or F0 irregularity in 
the voicing.

• VoiceSauce can also calculate measures that Praat can calculate:
• Pitch (F0), vowel formant, duration, intensity (RMS Energy)



What does VoiceSauce look like

Step 1

Step 2

Step 3

If you spot 
errors in the 
output and 
want to 
manually add 
data

If you want to 
visualize the 
data in 
VoiceSauce



Output from VoiceSauce

• VoiceSauce output one datapoint every 1 millisecond.

• VoiceSauce can also calculate mean
• Either the overall mean,

• Or you can specify how many intervals you want to divide a sound file into, 
and calculate the mean of each interval.



All data points:



Just the mean



Means of three equal-timed intervals for each file



What can you draw/analyze using output 
from VoiceSauce

    

  

  

    

  

  
  

    

  

  

    

  

  

  

   

   

   

   

            

         

 
  
 
 
 
 
 
 
  
 
 
 

Pitch track (F0 track of the seven tones in Xiapu Min)



What can you draw/analyze using output 
from VoiceSauce

  

 
 

                                           

   

   

   

   

   

   

   

   

   

   

  

 

 

 

 

 

 

 

 

Vowel chart (stressed and unstressed vowels in Cahuilla)



What can you draw/analyze using output 
from VoiceSauce
Boxplots of various measures

  

 

 

                  

 
 
 
  

 
 
  
  
  
 
  
 

H1*—H2* F0 Harmonic-to-noise ratio



Summary of the parameters

• F0: F0 from Straight (strF0), Snack (sF0), Praat (pF0), Subharmonic to 
harmonic ratio F0 (shrF0)

• Formant: Formant frequencies and bandwidths by Snack (sF1, sF2) and 
by Praat (pF1, pF2)

• Spectral measures: H1, H2, H1H2c, H2H4c

• Energy: Energy (overall); Strength of Excitation (SoE)

• Noise: Cepstral Peak Prominence (CPP); Harmonic to noise ratios: HNR05 
(0-500Hz), HNR15 (0-1500Hz), HNR25 (0-2500Hz), HNR35 (0-3500Hz), 
Subharmonic to harmonic ratio: SHR



Notes on harmonic amplitude correction

“The purpose of this correction formula is to ‘undo’ the effects of the 
formants on the magnitudes of the source spectrum. This is done by 
subtracting the amount by which the formants boost the spectral 
magnitudes.” (Iseli et al., 2007, p. 2285)



Notes on harmonic amplitude correction

• Formant correction formula from Iseli et al., 2007

• 𝐻(𝑤0) : The raw harmonic amplitude

• 𝑁: The number of formants to be corrected for

• 𝑟𝑖 = 𝑒−𝜋𝐵𝑖/𝐹𝑠

• 𝑤𝑖 = 2𝜋𝐹𝑖/𝐹𝑠
• 𝐹𝑖 : Formant frequency

• 𝐵𝑖  : Formant bandwidth

• 𝐹𝑠 : Sampling frequency



Notes on harmonic amplitude correction

• The correction becomes negative when a high-frequency harmonic is being corrected 
for a low-frequency formant

• Given:

#harmonic being corrected
f = 2000

#formant to correct
Fx = 450

#bandwidth of the formant being corrected

Bx = 34

#sampling rate
Fs = 44100

• Correction = -25.39
• Meaning that the correction of the formant at 450 Hz boosts the harmonic at 2000 Hz by 25.39 

db



Notes on harmonic amplitude correction

• The correction value of a formant at 450 Hz for harmonics from 100 to 
5000 Hz

   

   

 

  

                     

         

 
 
  
 
 
  
 
 
  
 
  
 
 
 
  
 
  
 
  

 
 
  
  
 
 



Notes on harmonic amplitude correction

• Cautions about the harmonic correction
• Does the correction formula really account for the attenuation of the formants on 

harmonics (i.e. does F1 at 450 Hz actually attenuates 25 dB on a 2000 Hz 
harmonic?)

• Notes from Yen Shue: 
• “Maybe the correction of formants shouldn't be applied on formants that are too 

far away from the harmonic of interest.”



Notes on harmonic amplitude correction

• The default formant correction setting (cannot be changed from the GUI. 
If you want to change what formants are being corrected for which 
harmonic, you need to change the MATLAB code.)
• H1: F1, F2

• H2: F1, F2

• H4: F1, F2

• A1 (the harmonic closest to F1): F1, F2

• A2 (the harmonic closest to F2): F1, F2

• A3 (the harmonic closest to F3): F1, F2, F3

• H2K (the harmonic closest to 2K): F1, F2, F3

• H5K (the harmonic closest to 5K): not corrected



Notes on harmonic amplitude calculation

• For raw harmonic amplitude calculation:
• The estimation of the harmonic amplitude depends on the estimation of f0. If the 

f0 is not correctly tracked, the harmonic frequency is not correctly tracked.
• If you detect f0 errors, you can either manually correct it in VoiceSauche “Manual” option, or 

throw that data point away from harmonic amplitude measures.

• For corrected harmonic amplitude calculation:
• The correction of harmonic amplitude depends on the correct tracking of:

• f0

• Formant

• If you detect f0 or formant tracking errors, you can either manually correct it in 
VoiceSauce “Manual” option, or throw that data point away from harmonic 
amplitude measures.



Sample research questions:

• Is the consonant pre-glottalized or post-glottalized?

• Are vowels following ejectives more glottalized than vowels following 
non-ejectives?

• Do implosive have stronger voicing than non-implosive?

• Does vowel quality differ between stressed and unstressed syllables?

• Do vowels after voiceless stops have a higher F0 than vowels after voiced 
stops?

• What is the F0 contour and shape of the tones in the language?

• Do vowels following aspirated stops have a breathy voice quality?



How to download and use VoiceSauce

• Windows users: Standalone .exe file

• Mac users: Install Matlab and run the scripts in Matlab

• Refer to https://yuanchaiyc.github.io/website/subpages/VS-
tutorial.html for detailed installation instructions

https://yuanchaiyc.github.io/website/subpages/VS-tutorial.html
https://yuanchaiyc.github.io/website/subpages/VS-tutorial.html


Case study for today

• The acoustics of V and VʔV in Hawaiian

• Hawaiian has phonemic glottal stop:

aha “what”

ʔaha “line, life”

noːu “yours”

noʔu “mine”

(Data and recordings from the UCLA Phonetics Lab Archive
http://archive.phonetics.ucla.edu/Language/HAW/haw_word-list_1973_01.html#1)



Case study for today

• Research question: Are the vowels surrounding the glottal stop 
creakier than the plain vowels?

• noːu vs. noʔu



Case study for today

• Word list:

word gloss word gloss word gloss

pe "thus" peːpeː "crushed" peʔe "to hide (oneself)"

nou "to throw" noːu "yours" noʔu "mine"

kou "yours" kouː "moist" koʔu "mine"

aka "shadows" aʔa "roots"

kaʔa "to roll"



Case study for today

• Parameters of interest:
• F0

• Harmonic amplitude: H1, H1—H2
• The lower the harmonic amplitude, the more glottal constriction

• Noise: Harmonic-to-noise ratio (HNR05, meaning between 0 to 500 Hz)
• The lower the HNR, the noisier the signal

• Amplitude of voicing: Strength of excitation (SoE)
• Glottalization tends to results in lower amplitude in voicing (SoE)



Getting started

• Prepare data in Praat
• Create a Textgrid

• Segment and annotate the target segment

• Save the Textgrid
• either as for the whole recording

• or split the recording into individual target words – RECOMMENDED

• You can use Praat scripts or Praat plugins to chop a long recordings into smaller chunks. 
Come talk to me if you want to know more about the tools!



Getting started

• Annotation strategy for the current task
• Segment out each vowel (monophthongs or nuclei and glide in dipthongs)

• e.g. [peːpeː] → Segment out two [eː]s

• e.g. [nou] → Segment out [o] and [u]

• Assign label at the word level and the segment level
• Word level: peLpeL (use “L” to replace diacritic [ː] because VS does not allow special 

symbols)

• Segment level: 
• 1-e-long-modal

• position-vowel-length-phonation



Getting started



Getting started



Getting started

• Download the preprocessed data here:

• https://yuanchaiyc.github.io/website/subpages/sample/Hawaiian_da
ta.zip



Pass on the .wav and .Textgrid to VoiceSauce

Step 1



Step 1: Settings



Step 2: Parameter estimation

Step 2





If you are using Matlab 
online, make sure you 
deselect all the 
measures involving 
Praat.

Step 2: Parameter estimation



Step 2: Parameter estimation



Step 3: Output to text

Step 3



Parameters to 
select for today:

H1*
H1*-H2*
HNR05
strF0
sF1
sF2
SoE



Step 4: Visualize the output in Excel

• Open output.txt in Excel:
• Open Excel → Data → From Text/CSV





Step 4: Visualize the output in Excel

• Open output.txt in Excel:
• Open Excel → Data → From Text/CSV;

• Load the data;

• Save the data file as a .xlsx file.



Step 4: Visualize the output in Excel

• Draw boxplots:
• Boxplots present the median, first and third quantile, and the minimum and 

maximum of the data.

Picture from https://www.simplypsychology.org/boxplots.html



Step 4: Visualize the output in Excel

• Draw boxplots: H1-H2 distribution of modal vs. glottalized phonation
• Select the column of “phonation”; Press “ctrl” on the keyboard, and Select the 

column of “H1H2c_mean”



Step 4: Visualize the output in Excel

• Draw boxplots: HNR distribution of modal vs. glottalized phonation
• Select the column of “phonation”; Press “ctrl” on the keyboard, and Select the 

column of “HNR05_mean”

• Go to Insert → Charts → All charts → Box & Whisker → Press “OK”





Step 4: Visualize the output in Excel

• Draw boxplots: HNR distribution of modal vs. glottalized phonation

More glottalized

We see that vowels surrounding glottal stops have lower HNR than vowels that do not. 
This indicates that vowels in VʔV words are more glottalized than vowels in V or VV words.



Step 4: Visualize the output in Excel

• Draw boxplots: HNR distribution of modal vs. glottalized phonation
• You can filter the data and see how the plot changes.

• Filter the “position” column by only selecting “1”

• Then filter the “position” column by only selecting “2”

More glottalized

Position 1 Position 2



Step 4: Visualize the output in Excel

• Let’s try more graphsǃ
• Draw boxplots for H1H2c_mean (H1—H2), soe_mean (Strength of Excitation), 

strF0 (F0 using “straight” algorithm)



Step 4: Visualize the output in Excel

• Let’s try drawing graphs in R

• R studio online: https://posit.cloud/content/5398051

• R script offline: https://yuanchaiyc.github.io/website/subpages/VS-
tutorial.Rmd

https://posit.cloud/content/5398051
https://yuanchaiyc.github.io/website/subpages/VS-tutorial.Rmd
https://yuanchaiyc.github.io/website/subpages/VS-tutorial.Rmd


Outlier detection for f0, formant, and 
harmonic measures
• f0 tracking error detection:

• f0 is frequently wrongly-tracked for creaky phonation. I recommend plot the 
f0 track for each token and manually check the f0 track.



Outlier detection for f0 and harmonic 
measures (personal recommendation)
• Formant tracking error detection:

• For each vowel, calculate the Mahalanobis distance from each token to the 
center of that category. Tokens with a Mahalanobis distance larger than 
threshold are regarded as outliers (Garellek & Esposito, 2021; Seyfarth & Garellek, 2018).

  

  

                          

 

   

    

    

    

 

   

    

    

    

  

  

                       

     

    



Outlier detection for f0 and harmonic 
measures (personal recommendation)
• Harmonic amplitude outlier detection:

• Exclude tokens with f0 errors

• Exclude tokens with formant errors

• Exclude tokens with z-score larger than 3



Take-home message

• VoiceSauce is a tool for analyzing acoustics of sound signals;

• Its advantage are:
• Able to process a large batch of sound files in one sitting;

• Able to calculate parameters relating to voice quality;

• Able to compare different algorithms for one measure (e.g. F0, formants);

• The output is in a tab-delimited format and is ready to be passed on to 
statistical tests and data visualization.



Appendix: Measure explanation

• H1c, H2c, H4c: The amplitude of H1, H2, H4 after being corrected for 
formant(s)

• A1c, A2c, A3c: The amplitude of the harmonic closest to F1, F2, F3 after 
being corrected for formant(s)

• H2Kc: The amplitude of the harmonic closest to 2K after being corrected 
for formants

• H1H2c, H2H4c, H1A1c, H1A2c, H1A3c, H42Kc, H2KH5Kc: H1-H2, H2-H4, H1-
A1, H1-A2, H1-A3, H4-H2K, and H2K-H5K after being corrected for formants

• CPP: Cepstral Peak Prominence

• Energy: Root-mean-squared energy of the signal



Appendix: Measure explanation

• HNR05, HNR15, HNR25, HNR35: Harmonic-to-noise ratio between 0-500 Hz, 0-1500 Hz, 
0-2500 Hz, and 0-3500 Hz

• SHR: Subharmonic-to-Harmonic Ratio

• H1u, H2u, H4u, A1u, A2u, A3u, H2Ku, H5Ku: The raw amplitude of H1, H2, H4, A1, A2, A3, 
H2K, H5K

• H1H2u, H2H4u, H1A1u, H1A2u, H1A3u, H42Ku, H2KH5Ku: The raw difference of H1-H2, 
H2-H4, H1-A1, H1-A2, H1-A3, H4-H2K, H2K-H5K

• strF0: f0 calculated used STRAIGHT algorithm

• sF0: f0 calculated using SNACK algorithm

• pF0: f0 calculated using PRAAT

• shrF0: Subharmonic-to-Harmonic f0; represent the perceived f0 when there is 
subharmonics (diplophonia) (Sun 2002)

• oF0: other f0. Used to calculate f0 using your own algorithm



Appendix: Measure explanation

• sF1, sF2, sF3, sF4: F1, F2, F3, F4 calculated using SNACK algorithm

• pF1, pF2, pF3, pF4: F1, F2, F3, F4 calculated using PRAAT

• oF1, oF2, oF3, oF4: F1, F2, F3, F4 calculated using your own algorithm

• sB1, sB2, sB3, sB4: Bandwidth of F1, F2, F3, F4 using SNACK algorithm

• pB1, pB2, pB3, pB4: Bandwidth of F1, F2, F3, F4 using PRAAT

• oB1, oB2, oB3, oB4: Bandwidth of F1, F2, F3, F4 using your own 
algorithm

• epoch: the time point of the peak of each pulse

• SoE: Strength of Exicitation; the energy of the peak of each pulse.
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